Symantec VIP EGConsole User Store Connection test does not find OOB attributes when using an SSL connection
search cancel

Symantec VIP EGConsole User Store Connection test does not find OOB attributes when using an SSL connection

book

Article ID: 262106

calendar_today

Updated On:

Products

VIP Service

Issue/Introduction

EGConsole is reporting "no OOB attributes found" when doing a User Store connection test while SSL is enabled. If SSL is not used, and the connection uses port 389, then the OOB attributes are found and show in the test.

This error is a 'false-negative' only showing during the User Store connection test. The actual user logon is working and users can select OOB delivery methods in production.

Environment

Release : Enterprise Gateway - 9.10

Cause

This issue is only cosmetic with the User Store test. Changing the 'BaseDN' setting to an OU should allow VIP test to find OOB attributes in the test.

This is observed in older EG versions (9.9.1) as well.

Resolution

If Base DN in the user store is provided along with the OrgUnit (OU) it is retrieving the OOB attributes (ex: Base DN: OU=Users,dc=company,dc=com). If it is without the OrgUnit then it is not fetching OOB attributes (ex: Base DN: dc=company,dc=com) with SSL. 

 

Additional Information

Fix will be included in Enterprise Gateway version 9.10.2