When activating Fault-Tolerant DA, it fails with "WARNING: Cannot find the Consul ACL token"
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When activating Fault-Tolerant DA, it fails with "WARNING: Cannot find the Consul ACL token"

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Article ID: 261639

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Updated On:

Products

CA Performance Management Network Observability

Issue/Introduction

When attempting to activate or place into maintenance one of the Data Aggregators (DA) it fails with unable to find ACL token. For example:

[root@/opt/IMDataAggregator/scripts] # ./dadaemon activate
WARNING: Cannot find the Consul ACL token

Environment

DX NetOps CA Performance Management (CAPM) all currently supported releases

Cause

The DA is unable to find the acl-token.properties file. This could be due to the file being missing or the /DAShareRepo directory (in which it resides) not being properly mounted on the DA

Resolution

Fault-tolerant environments require a shared data directory. Check the da.data.home parameter in /etc/DA.cfg file on each machine

This shared data directory is normally set to be /DASharedRepo 
 
The acl-token.properties will be in da.data.home=directory. By default, this is usually:

/DASharedRepo/acl-token.properties

This file and directory need to be accessible from both DAs. So ensure that the directory is mounted correctly on both the primary and failover DAs and that they have write permission to it. And ensure that the acl-token.properties file can be read by the install user account on both DAs.