DB Password update error
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DB Password update error

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Article ID: 261581

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Updated On:

Products

CA Identity Manager

Issue/Introduction

Getting the following error while doing  DB password update

ERROR] Failed to Encrypt string. Error 1: Error: A JNI error has occurred, please check your installation and try again
2023 Mar 03 14:04:10 ip-##-##-###-##.<server name> encryptString Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/logging/log4j/core/appender/ConsoleAppender$Target

 

Environment

Release :  Vapp Identity Manger 14.4.1

Cause

This is due to missing log4j files under /opt/CA/wildfly-idm/standalone/deployments/iam_im.ear/library

Resolution

Apply the 2 log4j HF under 

https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/identity-suite/14-4/release-notes/Virtual-Appliance-Release-Notes/Hotfixes.html

in the section "Upgrade Patch to Fix Apache Log4j Issues"