Unable to authenticate to SRAdmin on fresh Spectrum install on Linux
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Unable to authenticate to SRAdmin on fresh Spectrum install on Linux

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Article ID: 261476

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Updated On:

Products

DX NetOps CA Spectrum

Issue/Introduction

While trying to perform a fresh install of 22.2.5 on a RHEL 8.x system we are getting a "SPC-INT-20026 Unable to authenticate with SRAdmin" error. We are getting this error when trying to use both the spectrum user account that was created, and the root account credentials.

I have confirmed that SRAdmin is installed and listening for connections.

 

[root@ev01plv-careport01 ~]# netstat -tupln | grep sradmin
tcp        0      0 0.0.0.0:46517           0.0.0.0:*               LISTEN      1092/sradmin.exe    
[root@ev01plv-careport01 ~]# systemctl status sradmin
● sradmin.service - LSB: SPECTRUM Remote Administration Daemon
   Loaded: loaded (/sw/SPECTRUM/SRAdmin/sradmin.sh; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2023-03-06 15:22:00 EST; 16h ago
  Process: 1073 ExecStart=/bin/bash /sw/SPECTRUM/SRAdmin/sradmin.sh start (code=exited, status=0/SUCCESS)
    Tasks: 1 (limit: 410304)
   Memory: 3.1M
   CGroup: /system.slice/sradmin.service
           └─1092 /sw/SPECTRUM/SRAdmin/sradmin.exe --start

 

Currently neither iptables or firewalld are active.

Environment

Release : 22.2
Component: Spectrum install

Cause

Possible issue with timing

Resolution

The customer set LAX_DEBUG=true;export LAX_DEBUG to debug the install. After configuring this setting, the install ran successfully.