EEM Installation and permission issue with AWS
search cancel

EEM Installation and permission issue with AWS

book

Article ID: 261440

calendar_today

Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

Trying to install EEM  in an AWS environment, however the install keeps failing with this message coming up in the install log:

DEBUG [main] [WinRegistry] Reading the registry returned: ERROR: The system was unable to find the specified registry key or value

Environment

CA Service Management

EEM

Cause

Virtual Machine provisioned by the AWS platform has software installation restrictions for the C: drive. 

Resolution

1. Due to restrictive permission on C: drive of the AWS virtual machine, continue to experience "Failed to move C:\Program Files\CA\SC\CAPKI\tmp\CAPKI5/Windows/amd64/64\capki\log\liblog_api.dll to C:\Program Files\CA\SC\CAPKI\CAPKI5/Windows/amd64/64\capki\log\liblog_api.dll [4]"

2. Manually remove installed components for CAPKI and EEM

3. Clean remnants components from Registry

4. Separately and manually install CAPKI using etpki_5_2_11-00_amd64_64bit_fips_VS2005 file (run from command line = setup.exe install caller=5211bit64 veryverbose). This installs CAPKI on C: drive.

5. Install EEM from CA SDM ISO to a custom drive and validate the functionality from the EEM interface

6. Move CAPKI to the preferred custom drive

7. Change Registry Keys to point to a correct (custom) drive

8. Modify Environment variables to point to the correct location

9. Recycled services

10. Validate/verify the functionality