Software Delivery tab shows status of (System reboot pending) for Managed Software Delivery Polices, when the system does not need a reboot
search cancel

Software Delivery tab shows status of (System reboot pending) for Managed Software Delivery Polices, when the system does not need a reboot

book

Article ID: 261151

calendar_today

Updated On:

Products

Client Management Suite IT Management Suite Server Management Suite Server Management Suite

Issue/Introduction

Symantec Management Agent (SMA) UI is showing that there is a Reboot Pending for certain Managed Software Delivery (MSD) Policies. 

The system does not need a reboot, as confirmed by the Powershell command GetPendingReboot.

Environment

8.6 RU3

Cause

Only policies that are not allowed to run due to "Restart computer" or "Log off user" should have (System reboot pending) displayed in the status. These options are set in the Advanced Options of the MSD Policy.

The problem occurred:

1) With every policy for which there was pre-install notification configured
2) With every policy with any compliance status that could not run because of Software Delivery Policy blocked by another policy requiring logoff or reboot

In the SMA screenshot above, Notepad 8.4.6.0 executed at 7:49, and then user canceled the Logoff. This triggered the other policies that were scheduled later to not execute and to post the (System reboot pending) message.

Resolution

This is a known issue in 8.6 RU3 and has been resolved in 8.7. Work is also being done on User Deferrals in 8.7 RU1.

Workaround: 

1) Don't use the MSD Option to not run Policy if System Reboot is pending.
2) Run the task again.  When the task runs next, it will update the Status flag.