Using the "Visibility in Agent UI" option. Still displaying the Software Policy that was set to Hide.
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Using the "Visibility in Agent UI" option. Still displaying the Software Policy that was set to Hide.

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Article ID: 260883

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Updated On:

Products

IT Management Suite Client Management Suite

Issue/Introduction

This "Visibility in Agent UI" feature was added in ITMS 8.6 RU1 Release as seen here:

 

Basically, the general idea for this feature is:

Hide policy information in the agent UI. 
To hide policy information in the Symantec Management Agent user interface,
1) right-click the policy in the left pane of the Symantec Management Console,
2) select
Visibility in Agent UI,
3) check
Hide in Agent UI, and click OK

However, it has been noticed that in some client computers, the hidden Software Component is still visible.

Environment

ITMS 8.6, 8.7

Cause

If the Agent Diagnostics option is turned on a client machine then the hidden Software Component will still be visible.

The Software Policy that is set to hidden will be still visible. This was done to allow troubleshooting of this functionality and make it a little bit easier and avoid not being able to know if some Software Policy was still set to be hidden in the Agent UI.

Resolution

In order to disable Agent Diagnostics on a client machine do the following:

1) Logged in as an User with Admin rights, open a command prompt as Administrator

2) Set the path to the Altiris Agent directory in the command prompt:

      c:\Program Files\Altiris\Altiris Agent

3) Run the following command line:

      aexagentutil.exe /nodiags

Additional Information