IDM start up with Workpoint error
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IDM start up with Workpoint error

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Article ID: 260831

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Updated On:

Products

CA Identity Manager

Issue/Introduction

IDM start up seeing the following error after upgrade from 14.3 to 14.4 on  WAS 8.5.5.20

WorkflowException occurred: The WorkPoint database version should be 4.40 for the WPDS DSN but is found to be not present in the WP_INI table for SECTION_NAME=Database and KEY_NAME=version. This may mean you are running against an incompatible or outdated WorkPoint database version. Please upgrade the WorkPoint database manually, or set the auto.db.create.or.upgrade property to true in the workpoint-server.properties file and restart the server.

However, the properties auto.db.create.or.upgrade property to true has been set but the problem remains

 

Environment

Release : 14.4 Identity Manger

                 WebSphere 8.5.5.22

Cause

Workpoint database has become corrupted during the upgrade

Resolution

Drop all WP tables and restart IDM