Blank window shows in SEPM when attempting a "Download file that the client quarantined" from the SEPM > Monitors > Risk Logs > Actions
search cancel

Blank window shows in SEPM when attempting a "Download file that the client quarantined" from the SEPM > Monitors > Risk Logs > Actions

book

Article ID: 260787

calendar_today

Updated On:

Products

Endpoint Protection

Issue/Introduction

When trying to download the quarantined items from the SEPM console, nothing happens and the resulting window is blank

Everything else is working fine.

You see entries similar to this in the reporting.log (%SEPM%\apache\logs):

20xx-01-25 12:xx:xx      ERROR:runcommand [DownloadQuarantine] > failed to connect to the database

Environment

SEPM 14.3 RU2 and newer with the SQL database configured to use Windows Authentication or Mixed Authentication 

Cause

When the DB instance name start with lower case "e" (i.e.: SQLserver.domain.net\endpoint), PHP treats it as a special character. Consequently, the connection to the database fails.

Resolution

There are two options to resolve this issue:

  1. Change the SQL SEPM DB's instance name to a different name which does not start with lower case "e",  then run the Management Server Configuration Wizard on the SEPM to reconfigure the connection

    or

  2. If your SQL SEPM DB instance name starts with a lower case "e", locate and backup the Reporter2.php file ( %SEPM%\Php\Include\Resources), then modify the following line (using your SQL SEPM DB instance domain and name):

    $dbserver="SQLserver.domain.net\endpoint";
    to
    $dbserver="SQLserver.domain.net\\endpoint";

Additional Information