DLP Discover Scan failing to extract content on MS Excel when Macros is enabled.
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DLP Discover Scan failing to extract content on MS Excel when Macros is enabled.

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Article ID: 260675

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Updated On:

Products

Data Loss Prevention Network Discover

Issue/Introduction

When running Network Discover Scan, some MS Excel files may fail with error "Failed to extract content".

Environment

DLP 15.X

Cause

When MS Excel macros is enabled, the discover scan may fail with error "Failed to extract content". 

Same error with Zip file containing MS Excel with macros enable.

Resolution

When facing the issue, disable all macros on the Excel file like below and run the scan again.

Additional Information

For a Zip file, when one file fails, DLP will stop the scan and throw "Failed to extract content" error. In that situation, unzip the file and remove any problematic file and rescan again.