Network Attack Logs are blank after upgrade to RU6
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Network Attack Logs are blank after upgrade to RU6

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Article ID: 260638

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Updated On:

Products

Endpoint Protection

Issue/Introduction

After upgrading the Symantec Endpoint Protection Manager (SEPM) to 14.3 RU6, the Network Attack Logs do not finish loading or show any results.

 

 

Environment

Release : 14.3 RU6

Cause

The FirewallQueries.php file did not get updated during the upgrade. This generally happens if the file was modified prior with customizations which will prevent the upgrade from replacing it.

 

The following error will be seen in the <SEPM Install Directory>\apache\logs\reporting.log file:  (the path mentioned may vary depending upon your install path)

PHP Fatal error:  Uncaught Error: Call to undefined function each() in C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\Php\Include\Firewall\FirewallQueries.php:2292

Resolution

To resolve this issue the old FirewallQueries.php file needs to be replaced with the new RU6 one as outlined below.

1) Stop the following services:
Symantec Endpoint Protection Manager
Symantec Endpoint Protection Manager API Service
Symantec Endpoint Protection Manager Webserver

2) Backup or rename the original file: 
<SEPM Install Directory>\Php\Include\Firewall\FirewallQueries.php

3) Replace that file with the one in the zip file attached to this KB. Be sure to unzip it and that the file name is "FirewallQueries.php"

4) Make sure the file permissions on that file just copied match those of the one you backed up or renamed, if not match them up to the original file.

5) Start the services:
Symantec Endpoint Protection Manager Webserver
Symantec Endpoint Protection Manager API Service
Symantec Endpoint Protection Manager

Attachments

1677249640716__FirewallQueries_RU6.zip get_app