Vantage task is receiving the error "GENTCPSV TCP/IP REQUEST: SOCKET FAILED: ERRNO= 47" during startup
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Vantage task is receiving the error "GENTCPSV TCP/IP REQUEST: SOCKET FAILED: ERRNO= 47" during startup

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Article ID: 260564

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Updated On:

Products

Vantage Storage Resource Manager

Issue/Introduction

During Vantage task startup, the following message is received in the beginning of MSGE0001 file: 

TCP/IP REQUEST: SOCKET        FAILED: ERRNO=   47                    
IPv6 is not supported by your TCP/IP Stack TCPIP. Will shift to IPv4 
Socket bound in IPv4 mode            

Environment

Release : 14.1

Cause

This was caused by using by an IPv6 address, when IPv4 IP address was expected.

Resolution

Vantage is able to shift to IPv4.  

Additional Information

Further info for the ERRNO= 47 code can be found in the "z/OS Communications Server: IP Sockets Application Programming Interface Guide and Reference (SC27-3660-00)" manual (be sure to reference the appropriate manual based upon z/OS level): 

https://www.ibm.com/docs/en/zos/2.1.0?topic=calls-sockets-return-codes-errnos

Information for this specific error code shows: 

47    EAFNOSUPPORT    bind2addrsel inet6_is_srcaddr    You specified an IP address that is not an AF_INET6 IP address    Correct the IP address. If the IP address is an IPv4 address, you must specify it as an IPv4-mapped IPv6 address.