Oracle CDB Creation Failed
search cancel

Oracle CDB Creation Failed

book

Article ID: 260555

calendar_today

Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager CA Service Catalog ASSET PORTFOLIO MGMT- SERVER CA IT Asset Manager

Issue/Introduction

Installing Service Management, an error indicating "CDB Creation" failed may arise when installing with an Oracle backend MDB database.

Examining %TEMP%\2\casm\install.log:

DEBUG [DeployThread: Configuring CA Service Management common tables] [InstallCDB] 02-23,16:01:03 Creating mdbadmin user in the orcl database...
DEBUG [DeployThread: Configuring CA Service Management common tables] [InstallCDB] 02-23,16:01:04 Failed to create the mdbadmin user (errorlevel=65096)
DEBUG [DeployThread: Configuring CA Service Management common tables] [InstallCDB] 02-23,16:01:04 Pre-process failed (errorlevel=400)
DEBUG [DeployThread: Configuring CA Service Management common tables] [InstallCDB] 02-23,16:01:09 Removed the "MDB_DATA" tablespace Removed the "MDB_INDEX" tablespace

Examining %TEMP%\2\casm\mdb\install_orcl.log

SQL> --CREATE USER mdbadmin PROFILE DEFAULT IDENTIFIED BY "&1" DEFAULT TABLESPACE &2 ACCOUNT UNLOCK;
SQL>
SQL> CREATE USER mdbadmin PROFILE DEFAULT IDENTIFIED BY "&1" DEFAULT TABLESPACE &2 QUOTA UNLIMITED ON &2 ACCOUNT UNLOCK;
CREATE USER mdbadmin PROFILE DEFAULT IDENTIFIED BY "XXXX" DEFAULT TABLESPACE MDB_DATA QUOTA UNLIMITED ON MDB_DATA ACCOUNT UNLOCK
            *
ERROR at line 1:
ORA-65096: invalid common user or role name

Environment

CA Service Management 17.3 and higher

Oracle 12c or higher

Cause

The original database that was installed for Oracle prior to installing Service Management was configured to be a Container Database (checked on by default during DB creation)

Resolution

Go into the Database Configuration Assistant and delete the existing Oracle Database, then create a new database, taking care to uncheck the "Create as Container database" setting: