NCM problem connecting to 'xx.xx.xx.xx', port 23: connection refused
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NCM problem connecting to 'xx.xx.xx.xx', port 23: connection refused

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Article ID: 260539

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Updated On:

Products

CA Spectrum

Issue/Introduction

NCM capture running configuration is not working for few devices.

Next error is displayed

SPC-OCC-10746: The opration failed
SPC-NCM-20007: Capture Running Script
Returned Error [252]: Connection error: Host xx.xx.xx.xx:
Error connecting to device: problem connecting to 'xx.xx.xx.xx', port 23: connection refused

Environment

Release : 21.2

Cause

The error message indicates that the connection on port 23 was refused.

The tcp port 23 is used for Telnet. The device should support Telnet otherwise it won't work.

 

Resolution

1. Search the device in Locater tab > Devices > By IP Address

2. Right Click it, and select Location > Configuration Manager

3. Select the NCM Family the device is member of, and select the Information tab

4. Under Device Configuration Transfer Settings > Capture Running Configuration Script
    The Additional Script Parameters section will indicate if for the Capture of the running configuration is telnet what is being used.

5. If the device doesn't support Telnet, but only SSH, right click the device, select Add to > Device Family, and select a custom device Family that uses SSH for the NCM Running configuration capture