Troubleshoot why a user cannot issue commands they are authorized for
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Troubleshoot why a user cannot issue commands they are authorized for

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Article ID: 260445

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Updated On:

Products

SYSVIEW Performance Management

Issue/Introduction

User is trying to use ACTSUM' command but is getting an error code saying they are not authorized for the command

Environment

Release : 17.0

Cause

External Security can be one source of interference.  

Resolution

1. First check the product security area to ensure the user is set up correctly:

Enter the command SECURITY and then select User Groups. Then issue command WHERE userID 

Select and review the group the WHERE command showed

Select and investigate the User IDs section

Select and investigate the Commands Section

Select and investigate the Commands Field section 

Select and investigate the command that is failing

 

2.  Check the Users TSO log, SYSVW STC and the SYSVUSR logs for security type errors.

3.  Check to see if external security may be overriding the permissions for the particular USERID

      Issue command SECURITY.   Then select the ADMIN group, and then select the Select External Security Section

4.  Finally set Debug for the USERID by issuing the following sequence of commands:

SECURITY, USER GROUPS, ADMIN, and select MISCELLANEOUS SECTION.

Add userID in question to the DEBUG USER ID. PF3 out. 

Have the user log off and back into SYSVIEW and attempt the ACTSUM command.  The debug security errors will be seen in the TSO userid STC output