Unable to open CDM probe GUI due to Package Editor error
search cancel

Unable to open CDM probe GUI due to Package Editor error

book

Article ID: 260366

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

I am trying to open the CDM GUI but I get an error:

Package Editor
Error while fetching user interface from central archive
Unable to open <path> for write.
Tried to open read-only file for writing, or file's sharing mode does not allow specified operations, or given path is directory.

 

 

Environment

  • Release: 20.4

Cause

  • Conflicting instances of DLL files
  • Some common examples include:

    • libiconv.dll
    • nimbus_AES.dll
    • nimbusI18n.dll

  • These files may become locked as soon as a probe GUI is launched and so you will get this error message if for instance the cdm probe v6.84 gui is open, and you try to open cdm v4.60.

Resolution

In future releases of CDM and other probes with DLL requirements, we will be employing DLL Versioning to ensure that each probe that requires a specific DLL will only try to access that version so that multiple DLL versions can be in place simultaneously.

For now, you can take the following steps:

1. Close all open instances of the CDM GUI

2. Open just one at a time

 

However, if the error persists even after closing all CDM GUI instances, take the following steps:

1. Navigate to the folder given in the error message (usually C:\Users\(your username)\AppData\Local\Temp\2\util\)

2. Delete the offending .dll files (or all files) from this location and try again