Defective power supply in Security Analytics appliance
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Defective power supply in Security Analytics appliance

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Article ID: 260348

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Updated On:

Products

Security Analytics

Issue/Introduction

The system reports that there is a bad power supply.  The power supplies for both the sensor and the storage are redundant and hot-swappable.  The most common problem with the power is a loose power cord. 

Environment

Dell server
Dell storage

Cause

The power may have been interrupted by a power change in the data center, loose power cords (both ends), loose power supply, or a failed power supply. 

Resolution

To diagnose the power supply failure, start with the easy and least expensive steps.

  1. Check both ends of each power cord. Push them in whether they are loose or not.
  2. Clear the pink banner in the GUI and wait to see if it comes back.
  3. Check with the data center to determine if there was a change to the power inside the rack, UPS, or power source.
  4. Check to see if other systems have had power failures.  This may have been caused by a power bump in the data center.
  5. Run diagnostics to determine if it was a one-time problem or if the power supply is still down.

There are very good diagnostics for Dell hardware.  The iDRAC on the server and the Web UI for the storage array will display any faults found.  These diagnostics are also able to collect logs and configuration. Connect to the iDRAC using your browser and review the system status on the home page.  After checking for issues in the environment and the power cords, are there any reported failures?

To review the hardware status of the storage array, you can use your browser by pointing it to the IP. 

  1. Log in with the administrator username and password. 
  2. Select System
  3. Sort by Health by selecting the left column.
  4. Look for anything with a status of Fault.
  5. Select that line and the cause will appear.
  6. If you can, take a snapshot and send it to support.

The cause will be important.  If it says "The power supply is not receiving any power" then check the power cord attached to the power supply indicated, Left or Right.  Check both supplies and both ends of the power cords.  If it is in a Failed state, take a snapshot as supporting evidence for Dell that we have performed some amount of diagnostics.

For the server side of the system, there is also a Web UI called the iDRAC.  This should be set up with an IP address and a cable attached.

  1. Login to the iDRAC with your browser. 
  2. If there is an existing problem, there will be a red banner with "SYSTEM HAS CRITICAL ISSUES" displayed.
  3. At the bottom of the page will be Recent Logs
  4. Take a snapshot and pass along the current status to support.
  5. The logs may also indicate problems that have been resolved.

If there is no current issue on either the storage array or iDRAC server console then the problem has been resolved.  Both systems will have historical records of any failures in the past. Review the records and search for the failure and the recovery.

All power supplies are fully redundant.  The system should be running properly but it is vulnerable to future power problems. Let support know what you find.