Custom List App won't load or filter button doesn't respond
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Custom List App won't load or filter button doesn't respond

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Article ID: 260347

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Updated On:

Products

Rally SaaS

Issue/Introduction

One user reported that she can't view the board she created. She has all necessary permissions and access. Now everything is blank. 

 

The board in question contains the Custom List App.

Environment

Release :

Cause

When your Custom List App won't load, it is usually due to a corrupt filter setting which prevents the board from loading.  Alternatively, the filter icon may not respond when you click on it.  Filters are saved as a Preference on a per-user basis.  To clear the potentially corrupt filter setting, you can delete the filter preference.  Each user experiencing this issue will need to walk through the process to clear their own preference. 

Resolution

  1. On your dashboard or a custom page, add the "Custom HTML" app from the App Catalog.
  2. Paste the Preference Deleter code from this URL into the HTML section of the Custom HTML app. and <Save>.
  3. You will be prompted to enter the Preference Name, enter:  customlist-grid
  4. Make sure there are no beginning or ending spaces in the entry and click Find Preference.
  5. For each preference that is found, please click the Delete button and confirm Delete Preference Permanently.
  6. Once you have deleted all preferences, click the Find Preference button again and ensure that you see a popup box titled Preference Not Found.
  7. Logout immediately (don't navigate to any other page, so as not to save any additional preferences).
  8. Now when you login the filter is gone from the Team Board and your board should load.