PAM and ServiceNow integration
search cancel

PAM and ServiceNow integration

book

Article ID: 260328

calendar_today

Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

 

We are using ServiceNow for Incident and Changemanagement (and other parts as well) but these two Request types can be embedded and used by a Policy View Request. Here comes the issue, the implementation of ServiceNow relies on the REST-API, PAM(SC) uses the SOAP method. I am currently building a SOAP-To-Rest Gateway and i wonder if you can help me with the SOAP Template for Send And Request so i can map it with the Response I receive from Service NOW Rest Api.

 

Environment

Release : 4.0, 4.1 

Cause

We do not have any soap template to provide to customers

Resolution

 

You can find the NIM documentation which contains the request payloads and responses related information at the below URL:

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/normalized-integration-management-for-service-management-/3-2/using/rest-api-v2/rest-api-v2-calls-for-incident-operations/create-an-incident-rest-api-v2.html

 

PAM to NIM interaction is being done via REST
NIM to ServcieNow integration is being done via SOAP

If PAM sends a payload to NIM via REST , it will consume that payload and translate into ServcieNow SOAP understandable format and execute on ServiceNow and provide a response back to PAM in JSON format.

so If PAM sends a payload like below to NIM  using NIM REST APIs:

NIM URL: http://localhost:8080/ca-nim-sm/api/v2/Incident

Payload form PAM to NIM via using the above NIM REST endpoint
{
"name" : "Test Incident"
}

NIM will convert the above payload like below SOAP request and send to ServiceNow:

SOAP Request for creating an incident:
==============================
 <?xml version="1.0" encoding="UTF-8" standalone="no"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
<SOAP-ENV:Header/>
<SOAP-ENV:Body>
<insert>
<short_description>Test Incident</short_description>
</insert>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>


SOAP Response from ServiceNow after creating the incident:
===============================================
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SOAP-ENV:Body>
<getRecordsResponse>
<getRecordsResult>
<active>1</active>
<activity_due/>
<additional_assignee_list/>
<approval>not requested</approval>
<approval_set/>
<assigned_to/>
<assignment_group/>
<business_duration/>
<business_impact/>
<business_service/>
<business_stc>0</business_stc>
<calendar_duration/>
<calendar_stc>0</calendar_stc>
<caller_id/>
<category>inquiry</category>
<cause/>
<caused_by/>
<child_incidents>0</child_incidents>
<close_code/>
<close_notes/>
<closed_at/>
<closed_by/>
<cmdb_ci/>
<comments_and_work_notes/>
<company/>
<contact_type>phone</contact_type>
<contract/>
<correlation_display/>
<correlation_id/>
<delivery_plan/>
<delivery_task/>
<description/>
<due_date/>
<escalation>0</escalation>
<expected_start/>
<follow_up/>
<group_list/>
<impact>3</impact>
<incident_state>1</incident_state>
<knowledge>0</knowledge>
<location/>
<made_sla>1</made_sla>
<notify>1</notify>
<number>INC11350454</number>
<opened_at>2023-02-17 11:57:42</opened_at>
<opened_by>6816f79cc0a8016401c5a33be04be441</opened_by>
<order>0</order>
<origin_id/>
<origin_table/>
<parent/>
<parent_incident/>
<priority>5</priority>
<problem_id/>
<reassignment_count>0</reassignment_count>
<reopen_count>0</reopen_count>
<reopened_by/>
<reopened_time/>
<resolved_at/>
<resolved_by/>
<rfc/>
<route_reason>0</route_reason>
<service_offering/>
<severity>3</severity>
<short_description>Test Incident</short_description>
<sla_due/>
<state>1</state>
<subcategory/>
<sys_class_name>incident</sys_class_name>
<sys_created_by>admin</sys_created_by>
<sys_created_on>2023-02-17 11:57:42</sys_created_on>
<sys_domain>global</sys_domain>
<sys_domain_path>/</sys_domain_path>
<sys_id>e1479c8a1b49ed14edd6ddb9ec4bcb79</sys_id>
<sys_mod_count>0</sys_mod_count>
<sys_updated_by>admin</sys_updated_by>
<sys_updated_on>2023-02-17 11:57:42</sys_updated_on>
<task_effective_number>INC11350454</task_effective_number>
<time_worked/>
<u_custom1/>
<u_custom2/>
<u_custom3/>
<u_doi_product>DOI</u_doi_product>
<u_rk>rk</u_rk>
<universal_request/>
<upon_approval>proceed</upon_approval>
<upon_reject>cancel</upon_reject>
<urgency>3</urgency>
<user_input/>
<watch_list/>
<work_end/>
<work_notes_list/>
<work_start/>
</getRecordsResult>
</getRecordsResponse>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>

NIM Will convert the above response in JSON format and send it back to PAM so PAM can consume it.