421 4.4.0 Unable to connect to DNS - try again later
search cancel

421 4.4.0 Unable to connect to DNS - try again later

book

Article ID: 260203

calendar_today

Updated On:

Products

Messaging Gateway

Issue/Introduction

Emails from a specific sender are having the Action on Message Audit Logs as: Rejected Message by MTA without any other information

When looking on Message Audit Logs we can se the entry:

2023 Feb 16 08:17:41 +04 (warning) ecelerity: [22298] LUA: RDNS: RDNS lookup for connecting IP x.x.x.x returned SERVFAIL 
2023 Feb 16 08:17:41 +04 (debug) ecelerity: [22298] scriptlet-00340: lua_resume returned 0 
2023 Feb 16 08:17:41 +04 (info) ecelerity: [22298] ML-REJECT: Rejection on: x.x.x.x:x, sent to host: x.x.x.x:x, Audit ID Not Available, 421 4.4.0 Unable to connect to DNS - try again later#015

Performing a reverse lookup with any DNS server configured on SMG returns SERVFAIL

Environment

Release: 10.7.X, 10.8.X

DNS validation enabled on SMG (Protocols > Settings > SMTP)

Cause

Messaging Gateway is unable to resolve the sender IP address in any of the configured DNS servers

Resolution

Confirm that Messaging Gateway can connect to the DNS servers configured in Administration > Configuration > host > DNS / Time

  1. Go to Administration > Utilities in the Messaging Gateway Control Center
  2. Select the scanner host you need to test in the pulldown menu
  3. Query the DNS for a known good hostname or mx record

If the DNS query returns an error, work with your internal firewall and DNS teams to ensure that Messaging Gateway has access to the configured DNS servers on UDP port 53 and that the DNS servers are not rate limiting queries from Messaging Gateway