IM - Verify Cluster Log Messages Missing With JBoss 7.4
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IM - Verify Cluster Log Messages Missing With JBoss 7.4

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Article ID: 259968

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Updated On:

Products

CA Identity Suite CA Identity Manager

Issue/Introduction

The following doc link mentions that you can verify the JBoss 7.2 EAP cluster configuration by reviewing the JBoss server.log file to check for the "backup announced" or "waiting live to fail" messages but they are not seen after migrating to JBoss 7.4 EAP:

https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/identity-manager/14-4/installing/install-on-jboss-or-wildfly/jboss-or-wildfly-cluster-installation/post-installation-for-the-cluster.html

Environment

IM 14.4.x with JBoss 7.4

Cause

Here is the response from RedHat support.

“we are talking about 2 different EAP version, which means that they will have different log output, because the version are different. I believe that newer version has a better log management and it remove WARN message of a clean shutdown. That's why you don't see these messages in the newer version anymore."

Resolution

Here is the response from RedHat support.

As we discuss an alternative way to know if the broker cluster is formed or not by using a CLI command to look to verify the cluster topology that gives you the exact number of nodes that the cluster current have:

/subsystem=messaging-activemq/server=default/cluster-connection=my-cluster:read-attribute(name=topology)