SAC RDP Application not working with Microsoft Remote Desktop for MAC 10.8.0.
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SAC RDP Application not working with Microsoft Remote Desktop for MAC 10.8.0.

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Article ID: 259962

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Updated On: 02-15-2023

Products

Symantec ZTNA

Issue/Introduction

SAC RDP Application fails with Microsoft Remote Desktop for MAC 10.8.0, downloaded from the App Store.

Users report 'Unable to connect' error shown below:

Previously used Microsoft Remote Desktop for MAC 10.7.9 which worked fine.

Users reporting issue with different MAC OS versions like Catalina, Monterey and Big Sur.

Problem only visible when using the MacOS RDP client with Secure Access Cloud ; without Secure access cloud there are no issues using MacOS RDP client.

Environment

Microsoft Remote Desktop for MAC 10.8.0.

MacOS version 12.x and 13.x.

SAC.

Cause

Update to Microsoft Remote Desktop MacOS client broke functionality.

Resolution

The following workaround can be applied if staying on Microsoft Remote Desktop for MAC 10.8.0:

  • launch Terminal Application
  • type following on the terminal console: defaults write com.microsoft.rdc.macos ClientSettings.DisableOnPremWebSocketGateway true

This setting bypasses the WebSocket connection attempt and simply connects with plain https channels.

Note: Performance-wise WebSocket is expected to be faster than https channels. For deployment en-masse, if you can push policies to the managed MacOS devices, we would suggest this option (after verifying it works on your MacOS host). However, if these are not managed macOS devices, then we would suggest uninstalling Microsoft Remote Desktop for MAC 10.8.0, installing Microsoft Remote Desktop for MAC 10.7.9 and waiting for an official fix to be pushed to the Appstore.