Could not open CAPKI shared library, errno is 126 when trying to register a SM agent
search cancel

Could not open CAPKI shared library, errno is 126 when trying to register a SM agent

book

Article ID: 259837

calendar_today

Updated On: 04-16-2025

Products

SITEMINDER

Issue/Introduction

Installing the SM agent on IIS, the agent fails to initialize.

The logs indicate that host registration was skipped.

Manually registering the host with smreghost returns the error, "Could not open CAPKI shared library, errno is 126".

Attempting to start the LLAWP.exe also returns the error, "Could not open CAPKI shared library, errno is 126".

Environment

OS: Windows 2016 or 2019
Release : 12.8.x

Cause

The error indicates an issue with the capki structure.

Resolution

If there are no other SiteMinder components installed on the system. Follow these steps:

  1. Uninstall the agent.
  2. With the fsutil command, enable 8dot3names "fsutil 8dot3name set VolumePath 0".
  3. Verify that the capki is removed from the path "<install dir>\SC\CAPKI". And another path that may have been used previously.
  4. Set "IIS_IUSRS with full control to the E:\CA\webagent directory
  5. Verify the CAPKI directory is present and files are populated.
  6. Reinstall the agent.
  7. Attempt to register the agent.

Additional Information

Steps to manually register the host:

In <path to agent installation>\bin directory:

smreghost -i policy_server_IP_address:[port] -u administrator_username -p administrator_password -hn hostname_for_registration -hc host_configuration_object -o

(NOTES: Separate each command argument from its value with a space. Surround any values that contain spaces with double quotes.)

Then in a command window with Run as Administrator, restart IIS by running the command "iisreset" and start the llawp.exe process manually.

Run command "<path to agent installation>\bin\LLAWP.exe" "<path to agent installation>\bin\IIS\WebAgent.conf" -IIS100 -a -c"