Duration for a task increases when opened from MSP
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Duration for a task increases when opened from MSP

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Article ID: 259802

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

You are opening a project in MSP.  When it opens, the duration for some tasks is increased.  There are no assignments and the task is set to a fixed duration.

The expectation is that the duration does not change.

Environment

Release : All supported releases

Cause

This is caused by the Standard Calendar and the non-working days that have been defined.

 

Resolution

This is working as designed as the concept of a project calendar does not exist in Clarity. Clarity uses the Standard calendar for the majority of its scheduling (when the auto-schedule job is run). Also, Clarity is a resource-based scheduler, so the calendars used in scheduling are only the ones that are associated with resources on that project team.

There are two options 

  1. If there are no resources assigned to the task, Clarity will use the Standard Calendar.  Use the out-of-the-box Standard Calendar without the previous non-working days that were defined.
  2. Create a dummy resource with 0 ETCs and assign to the task.  This will respect the resource calendar and not the Standard Calendar.