Interactive installation of CU4/CU5 patch fails with error : That Product component is not installed on that node.
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Interactive installation of CU4/CU5 patch fails with error : That Product component is not installed on that node.

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Article ID: 259596

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

Manual interactive installation of CU4 or CU5 patch (Agent/Server/Explorer) with applyptf.exe returns following error :
That Product component is not installed on that node.
 

Environment

Client Automation 14.5 CU4 or CU5

Cause

The .jcl file contains these lines :

FILE:#TNGDTS-30#\bin\dtscli.exe:SKIPIFNOTFOUND:
FILE:#TNGDTS-30#\bin\dtscore11.dll:SKIPIFNOTFOUND:
FILE:#EGC30N#\EGC30N.dll:SKIPIFNOTFOUND:
FILE:#TNGDTS-30#\bin\tngdta.exe:SKIPIFNOTFOUND:
FILE:#TNGDTS-30#\bin\dtfzlib.dll:SKIPIFNOTFOUND:

If DTS Agent and/or DSM Explorer is not installed on the agent, applyptf.exe could not resolve the variables #TNGDTS30# and/or #EGC30N#. It returns error "That Product component is not installed on that node."

 

Resolution

There are 2 possible solutions :
 
1- Use the installation command line :
Example for CU5 agent patch (99111570) :
 
DeployWrapper.exe /INST ApplyPtfInstall /PTF=99111570.jcl /SILENT /INSTALLNEW  /OUTPUTFILE=99111570.log
 
or
 
APPLYPTF.exe /NODE=computername  /PTF=99111570.jcl /SILENT /INSTALLNEW  /OUTPUTFILE=99111570.log
 
change computername by the correct hostname
 
OR
 
 
2- With applyptf.exe in interactive mode :

Edit file 99111570.jcl and replace the lines
 
FILE:#TNGDTS-30#\bin\dtscli.exe:SKIPIFNOTFOUND:
FILE:#TNGDTS-30#\bin\dtscore11.dll:SKIPIFNOTFOUND:
FILE:#EGC30N#\EGC30N.dll:SKIPIFNOTFOUND:
FILE:#TNGDTS-30#\bin\tngdta.exe:SKIPIFNOTFOUND:
FILE:#TNGDTS-30#\bin\dtfzlib.dll:SKIPIFNOTFOUND:
 
by these lines :
 
FILE:..\SC\DTS\bin\dtscli.exe:SKIPIFNOTFOUND:
FILE:..\SC\DTS\bin\dtscore11.dll:SKIPIFNOTFOUND:
FILE:..\SC\EGC\EGC30N.dll:SKIPIFNOTFOUND:
FILE:..\SC\DTS\bin\tngdta.exe:SKIPIFNOTFOUND:
FILE:..\SC\DTS\bin\dtfzlib.dll:SKIPIFNOTFOUND:
 
This second solution does not work if DTS agent and/or DSM Explorer are installed on the Agent/Server machine but with a different path than DSM.
 
Example :
DSM installed under C:\Program Files (x86)\CA\DSM
SC installed under D:\Program Files (x86)\CA\SC