Apache Tomcat V10 compatibility with Automic Automation V 12.3 and V21
search cancel

Apache Tomcat V10 compatibility with Automic Automation V 12.3 and V21

book

Article ID: 259558

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Apache Tomcat vulnerability for Automic Automation v12.3 (UC4)

Requesting Broadcom to support the latest supported version for Apache Tomcat. V 10 with Automic 12.3.X and 21.X

Environment

Release : 12.3.X and 21.X

Cause

Compatibility

Resolution

AWI is designed for running under Tomcat 9 but in order to run under Tomcat 10 breaking changes must be developed as Tomcat 10 is not upward compatible to Tomcat 9 (from AWI's point of view).

Please check:  https://tomcat.apache.org/migration-10.html


There is a significant breaking change between Tomcat 9.0.x and Tomcat 10.0.x. The Java package used by the specification APIs has changed from javax... to jakarta....

As an alternative, you can use the "build-in" Jetty launcher of AWI v21. But nothing for Automic V 12.3