Quarantine shows as Inactive following upgrade to SMG 10.8 and cannot be changed.
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Quarantine shows as Inactive following upgrade to SMG 10.8 and cannot be changed.

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Article ID: 259536

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Updated On:

Products

Messaging Gateway

Issue/Introduction

For a small number of SMG installations, following the upgrade to Messaging Gateway (SMG) 10.8.0, messages can be released from the Quarantine individually but not multiple messages at a time. When checking the Administration > Configuration page, the Quarantine shows as Inactive and cannot be activated.

Attempting to activate the Quarantine returns success but the Quarantine remains inactive.

Environment

Release : 10.8.0

Cause

This is usually the result of a failure of the SMG Control Center web application to resolve its own hostname or connect to the local agent service.

Resolution

Hostname DNS resolution

  1. Go to Administration > Configuration and edit the configuration for the Control Center host
  2. Note the value in the Host name field.
  3. Go to Administration > Utilities > Troubleshooting
  4. Select the Control Center host in the Host pulldown menu
  5. Enter the value for the hostname from step 2 in the Host name or IP address field
  6. Click Run

If the DNS query comes back with an error similar to the following, then the SMG hostname does not exist in the DNS:

Cannot execute nslookup.
*** Invalid option: silent Server: 127.0.0.1 Address: 127.0.0.1#53 ** server can't find reference.smg.lab: NXDOMAIN

To address this, please ensure that the hostname or the SMG Control Center resolves in the DNS to one of the IPs assigned to the SMG Control Center host

Agent service access control list

  1. Log into the Control Center command line interface as admin
  2. Run agent-config --status
  3. Confirm that the IP address of the first ethernet interface (eth0) is listed in the output
  4. If both 127.0.0.1 and the IP address of eth0 is not listed run agent-config -a [ip address] to add the missing IP address
  5. Restart the agent service a second time (note, this second service restart is required in 10.8.0 and 10.8.1 to update the firewall configuration)
  6. Run agent-config --status a second time confirm that the access control list is set properly

Example

cc [10.8.1-7]> agent-config --status
127.0.0.1
Current log level is warnings
cc [10.8.1-7]> agent-config -a 10.20.30.40
Please wait while the agent restarts .....
cc [10.8.1-7]> service agent restart
Restarting agent (via systemctl):                          [  OK  ]
cc [10.8.1-7]> agent-config --status
127.0.0.1
10.20.30.40
Current log level is warnings