No VNA Alarms\Events are not being displayed in Spectrum
search cancel

No VNA Alarms\Events are not being displayed in Spectrum

book

Article ID: 259351

calendar_today

Updated On:

Products

CA Virtual Network Assurance

Issue/Introduction

No VNA Alarms\Events are not being displayed in Spectrum but all of the devices are displayed correctly under SDN Manager within OneClick Console.

server.log shows the following exception

2023-02-01 10:14:51,712 WARN  (Camel (camel-1) thread #1 - JmsConsumer[InventoryUpdateQueue])  [org.apache.camel.component.jms.EndpointMessageListener] CamelLogger 214  Execution of JMS message listener failed. Caused by: [org.apache.camel.RuntimeCamelException - java.lang.IllegalStateException: Queue full]: org.apache.camel.RuntimeCamelException: java.lang.IllegalStateException: Queue full at deployment.core-22.2.4-RELEASE.war//org.apache.camel.RuntimeCamelException.wrapRuntimeCamelException(RuntimeCamelException.java:51)

Environment

Release : 22.2.x

Cause

  • The VNA InventoryUpdateQueue is filling up.   
  • This queue is the bus between OneClick and the broker.
  • The queue is filling up because the CPUs cannot keep up with message\alarm processing.

Resolution

  • Increase the number of cores on the VNA System
  • General guidance is 1 core per engine configured + 1 (4 engines configured = 5 cores)
  • It is not recommended to run more than 3 or 4 Engines per VNA.
  • Please reference the DX NetOps Sizing Tool linked below.

 

Additional Information