Soap call fails, but returns successful in IDM
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Soap call fails, but returns successful in IDM

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Article ID: 259266

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Updated On:

Products

CA Identity Manager

Issue/Introduction

Making a soap call to Top Secret via an Action Rule in a PX Policy. The result on IDM indicates success.  But on the Top Secret side there is an error:

OSDTSAPI - 01/27/2023 14:06:56 - 3822 PERMIT - Error accessing <TableName>.

Why doesn't the PX Policy report this failure?  Is there a way to get an IDM response with failed that reflects the endpoint result

 

Environment

Release : 14.4 Identity Manager

Cause

IDM is using the response from the endpoint to determine failed or successful.  If the response is showing 200 OK, IDM is thinking the SOAP call went successfully.  

Resolution

Adding a setting in Top Secret so that including a particular attribute in the soap call would cause a 500 error instead of 200 to be returned if an exception code is returned.