Unable to Discover new device, SNMPWALK works ok
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Unable to Discover new device, SNMPWALK works ok

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Article ID: 259129

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Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

Unable to Discover new device in PC Console using V3, SNMPWALK works ok

Discovery results - Inaccessible

..

SNMPWalk ok

 

[root ~]$ snmpwalk -v3 -u v3user -l authPriv -a SHA -A authpass -x AES -X privpass 10.101.20.67

 

SNMPv2-MIB::sysDescr.0 = STRING: HPE Comware Platform Software, Software Version 7.1.070, Release 3506P02

HPE 5510 48G PoE+ 4SFP+ HI 1-slot Switch JH148A

Copyright (c) 2010-2019 Hewlett Packard Enterprise Development LP

SNMPv2-MIB::sysObjectID.0 = OID: SNMPv2-SMI::enterprises.25506.11.1.218

..

In dcdebug discovery logging by IP, we see this:

======= Response for DC dchost:frto445-2fe1-4c50-b953-545957b8d186 =======

Search string 10.10.10.20 returned 21 results (5,026 bytes)

 

Jan 27 15:30:26.806: IP: 10.10.10.20 Profile discovery started

Jan 27 15:30:26.807: IP: 10.10.10.20 Starting SNMP profile discovery for profile: [rank=1, [email protected], name=Network_Devices]

Jan 27 15:30:35.808: IP: 10.10.10.20 Profile discovery result for profile: [rank=1, [email protected], name=Network_Devices]: REQUEST_TIMED_OUT, Response PDU: null

 

======= Response end for DC spm5632:c6200ff0-2fe1-4c50-b953-545957b8d186 =======

Environment

Release : 22.2

Cause

If there is a duplicate V3 engineid detected during discovery, dcdebug will show timed out message.

Please check the DC karaf.log for this message:

grep “Duplicate EngineID detected” karaf.*

 

And saw that there are many devices with duplicate v3 engineid’s.

And this is what is preventing us from discovering the device.

 

Karaf.log.1

 

Line 767659: 2023-01-24T15:23:05,327 | ERROR | Response Pool.3  | MPv3Proxy                        | m.ca.im.dm.snmp.snmp4j.MPv3Proxy  978 | 54 - com.ca.im.data-collection-manager.snmp - 22.2.4.RELEASE-611 |  | Duplicate EngineID detected: 80:00:1f:88:98:50:a8:f6:5b:ab:1c:11:63:45:00:00:00, IP(s) associated [10.10.10.20/161, 10.10.10.30/161]

Resolution

Every V3 device in your network requires a unique engineID.

Fix the engineID and rediscover the device.

Note: if you cannot fix the engine id, you can discover the device on a different DC, as the unique list is per DC.

Additional Information

The Duplicate EngineID detected message will be added to dcdebug in a future build.

https://knowledge.broadcom.com/external/article/32071/