Users report "Using CTCv1 (missing enrollment token)" warning after upgrading to WSS Agent 8.3.1 or later
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Users report "Using CTCv1 (missing enrollment token)" warning after upgrading to WSS Agent 8.3.1 or later

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Article ID: 259124

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Updated On:

Products

Cloud Secure Web Gateway - Cloud SWG

Issue/Introduction

After upgrading to WSS Agent v8.3.1, users report the agent status screen warning message: "Using CTCv1 (missing enrollment token)": 


Notes: 

  • The warning appears regardless of which Cloud SWG POP the user connects to.
  • The warning was NOT displayed with previous versions of WSS Agent (prior to 8.3.1).

 

Environment

(1) WSS Agent 8.3.1 and newer.

(2) In the Cloud SWG Portal, the following checkbox is NOT enabled in the WSS Agent options: 

"Block legacy CTC communications" 

Cause

The WSS Agent enrollment token is not included with upgrade installations, resulting in the warning.

Resolution

In this state, Enhanced CTC will not function, even though it is supported on WSS Agent 8.3.1.

To eliminate the warning and establish the ability to use Enhanced CTC (CTCv2):

(1) Uninstall the current WSS Agent

(2) Performing a clean (new) installation of WSS Agent version 8.3.1

The fresh install triggers the installation of the enrollment token, which is necessary for Enhanced CTC.

Additional Information

This is a cosmetic message, and will not impact normal WSS Agent functionality.

However, it does prevent the ability to use new enhanced CTC services.  Therefore, administrators should NOT select the "Block legacy CTC communications" option in the Cloud SWG portal until ALL of their WSS Agents are connecting to the service.


IMPORTANT:

  • Do NOT disable legacy CTCv1 WSSA clients by enabling the "Block legacy CTC communications" option in the WSS Agent settings in Portal when this warning is present. Doing so will result in WSS Agents (prior to v8.3.1) from being unable to connect to the Cloud SWG service.

 

KB on: "Block legacy CTC communications"