Error: Unable to decode SMSESSION cookie in Web Agent from API Gateway
search cancel

Error: Unable to decode SMSESSION cookie in Web Agent from API Gateway

book

Article ID: 259121

calendar_today

Updated On:

Products

CA Single Sign On Agents (SiteMinder) SITEMINDER CA API Gateway

Issue/Introduction

 

Running Web Agent, when this one receives a SMSESSION cookie from API Gateway Agent, the Web Agent reports the error:

    Unable to decode SMSESSION cookie

 

Cause

 

There's an issue where API Gateway caches cookies. and solved in API Gateway 11.0 (1), and with a patch of the 10.1SP2 (2).

A workaround is also available to fix that problem (3).

 

Resolution

 

Upgrade API Gateway to 11.0 (1) or 10.1SP2 patch v10.1.00.14326-CR02 (2), or work around the issue (3) to solve the issue.

 

Additional Information

 

(1)

    Issues Resolved in Version 11.0

      | Fixed Issue ID | Description                                                                 |
      |----------------+-----------------------------------------------------------------------------|
      | DE544265       | Resolved cookies caching issue during request or response handling and when |
      |                | Gateway is making an outbound route.                                        |

    

(2)

    Issues Resolved in Version 10.1 CR2

      | Fixed Issue ID | Description                                                            |
      |----------------+------------------------------------------------------------------------|
      | DE544265       | Resolved cookies caching issue during request or response handling and |
      |                | when Gateway is making an outbound route. (Resolved in v10.1.00.14326- |
      |                | CR02)                                                                  |

    

(3)

    Cookie saved and reused in 10CR2 for different request