Resource Allocations portlet: System error with Date Range fields in filter
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Resource Allocations portlet: System error with Date Range fields in filter

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Article ID: 259106

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

The Resource Allocations portlet throws a system error when filtering on a Date field set on a Date Range format

STEPS TO REPRODUCE:

  1. Go to Home > Resource Management > Resources
  2. Open any given resource profile
  3. Go to the Allocations tab
  4. Go to Options > Configure > List Filter Section
  5. Add the Finish field (pravailfinish) to the filter
  6. Set its Display Type as Date Range
  7. Populate the desired date range and filter

Expected Results: The portlet do filter down with the provided date range

Actual results: You get: System error. Contact system administrator.

 

Environment

Clarity PPM 16.0.3 and 16.1.0

Cause

This is caused by DE67411

Resolution

Workaround: You can use the Finish field on a power field instead. Example of expression:

( ( Team Finish >= '01/02/23' ) and ( Team Finish <= '16/02/23' ) )

This is fixed in 16.0.3.3 and 16.1.1

Additional Information

This was not an issue up to 16.0.2. It only affects 16.0.3 and 16.1.0

app-ca.log file shows the following error:

ERROR 2023-02-02 09:06:01,923 [https-jsse-nio2-443-exec-92] niku.xql2 (clarity:admin:5238060__017C2B96-CAA1-42F0-976C-9C4DA0476DCD:npt.gridFilter) Internal Processing exception
java.lang.Exception: Failure while evaluating "getRecordCount('qrowdata')" in expression "{getRecordCount('qrowdata')}" error: Invalid expression getRecordCount('qrowdata'): com.niku.union.persistence.PersistenceException: 
SQL error code: 1861
Error message: ORA-01861: literal does not match format string