Custom Spectrum OneClick Roll for NCM privileges not working
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Custom Spectrum OneClick Roll for NCM privileges not working

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Article ID: 259065

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

I created a custom roll that contains all of the NCM Privileges and assigned the Roll to a custom Security Community which is associated to a User Group.

When a User from the User Group logs into OneClick, the Configuration Manager folder is not seen in the Explorer tab in the Navigation Panel as expected.

 

Environment

Release : Any
Component: OneClick

Cause

Out of the box, the Configuration Manager model has the ADMIN Security String configured. Since the custom Roll with the NCM Privileges is assigned to a custom Security Community that is not ADMIN, the user will not have access to  the Configuration Manager folder.

Resolution

Add custom Security String to the Configuration Manager model. 

- Log into OneClick as an ADMIN user

- Find and select the Configuration Manager model

- Click on the Attributes tab in the Component Detail panel

- Find and select the Security_String attribute

- Edit the value of the Security_String and add the custom Security Community. For example, if the custom Security Community is "NCM", the value of the Security_String attribute would be "ADMIN|NCM".

- Save the change