Message "Table in use" when trying to edit an OPS/MVS RDF table.
search cancel

Message "Table in use" when trying to edit an OPS/MVS RDF table.

book

Article ID: 25900

calendar_today

Updated On:

Products

OPS/MVS Event Management & Automation

Issue/Introduction

When trying to update one RDF tables, as STCTBL for example, the following error message can occur:

TABLE IN USE userid ON system HOLDS THE ENQ ON TABLE system>STCTBL                          

 

 

Environment

OPS/MVS-Event Management & Automation-for JES2
 

Cause

An unexpected termination of an user may leave an enqueue of a table in the held state.

Resolution

 

If an OPSMVS SSM table is ENQUEUED or hung you can try one of the following methods to free it

Access the following panels via the OPSVIEW Primary Options Menu:

1) Using panel 2.6:
         Type F at table name that is hung to free it.

2) From an ADDRESS TSO environment:

       OI ASOTEAPI FREE TABLE(table_name) {USER(system>userid)}

 

If the methods above do not work, then perform the following...

3) Using panel 4.8

- Use GLVTEMP# being # 0 or 1 in the "Global Prefix" field

- Then find the userid that is holding the table, type D to free it.

 

 

Additional Information