Getting 400 bad request when using SAC Web Application
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Getting 400 bad request when using SAC Web Application

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Article ID: 258854

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Updated On:

Products

Symantec ZTNA

Issue/Introduction

SAC users reporting an issue with accessing web application and receives 400 bad request error after entering user credentials.

Under the SAC portal the application itself is showing as online and logs are showing success access this application.
  - The end users would always get a popup for their credentials before an error message would return.

Environment

Release : 1

Cause

The initial request triggers a 401 auth response, asking users for NTLM credentials. The subsequent requests should have the Authorization HTTP header with the NTLM credentials but it does not send any hence why we send a 400 bad request response.

 

Resolution

If the application uses NTLM, Kerberos or basic authentication methods, you should use Enforce session stickiness by IP and port under the Advanced Web Application Settings: