Spectrum APM SaaS integration error using a proxy.
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Spectrum APM SaaS integration error using a proxy.

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Article ID: 258769

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Updated On:

Products

CA Spectrum

Issue/Introduction

The following error is seen when trying to integrate APM SAAS with Spectrum through a proxy:

SaaS APM REST URL = https://axa.dxi-na1.saas.broadcom.com:443/apm/appmap/graph/vertex

 Payload to get Agents from SaaS : = {
            "orItems":[
                {
                    "andItems":[
                        {
                             "itemType" : "attributeFilter",
                             "attributeName": "type",
                             "attributeOperator": "IN",
                             "values": [ "AGENT" ],
                             "layer":"APM_INFRASTRUCTURE" 
                         }
                    ]
                }
            ]
        }

ERROR : Connection timed out (Connection timed out)

Environment

Release : 22.2.*

Cause

The customer requires all traffic to go through a proxy to the internet. The APM SAAS/Spectrum integration does not support using a proxy at this time.

Resolution

The Spectrum to APM SAAS integration does not support going through proxy at this time.