DLP Discover scan failed with code 3707
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DLP Discover scan failed with code 3707

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Article ID: 258680

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Updated On:

Products

Data Loss Prevention Network Discover Data Loss Prevention Data Loss Prevention Enforce

Issue/Introduction

Enforce Console > Manage > Discover Scanning > Discover Targets shows a failed scan status.


The Discover Server shows event code 3707 - Scan failed: Remediation detection catalog could not be updated

Environment

Data Loss Prevention 15.8 GA

Cause

From the FileReader log:

com.vontu.discover.fsm.StateMachine catalogUnavailable
INFO: Remediation detection catalog update timed out after 1,800,000 seconds for target <Discover scan name>

Resolution

  1. From Enforce, ensure all scans targeted to the impacted Detection Server are in stopped state.
  2. Stop the SymantecDLPDetectionServerController service on the Detection Server.
  3. On the same Detection Server go to the following directory (this is the default path but will vary depending on where DLP is installed).

    Windows: \ProgramData\Symantec\DataLossPrevention\DetectionServer\<dlp version>\scan\catalog 
    Linux: /var/Symantec/DataLossPrevetion/DetectionServer/<dlp version>/scan/catalog

  4. Take a backup of RemediationResiliencyStorage folder (copy entire folder in a backup folder outside of where DLP is installed)
  5. Delete the RemediationResiliencyStorage folder from catalog folder.
  6. Restart the SymantecDLPDetectionServerController service.
  7. Restart your Discover Scan.