The "Contact Lost Model Destruction" in Spectrum is not deleting models it should be deleting
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The "Contact Lost Model Destruction" in Spectrum is not deleting models it should be deleting

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Article ID: 258645

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

We have the "Contact Lost Model Destruction" in Spectrum enabled and configured to delete models that have been in a lost contact status for more than 30 days.

We are seeing models in Spectrum that have had lost contact status longer than 30 days not being deleted as expected.

Environment

Release : Any

Cause

For this specific issue, it was found there is a serious performance issue in the SpectroSERVER causing significant latencies in the work threads.

Resolution

If you are experiencing performance issues in Spectrum, please open a case with Spectrum Support to investigate and resolve the root cause of the issue.

Additional Information

To get a head start when opening a case for a performance issue in Spectrum, please collect perfCollector9 and moot trace data and upload to the case.

To run perfCollector9:

1. Log into the SpectroSERVER system as the user that owns the Spectrum installation

2. If running Windows, start a bash shell by running "bash -login"

3. cd to the $SPECROOT directory

4. Remove the Performance directory if present

5. Execute the following command where <HOST> is the hostname of this system:

./perfCollector9 <HOST>

6. When complete, upload the $SPECTRUM/Performance/results.tar.gz file to the case for analysis

To run a moot trace:

1. Log into the SpectroSERVER system as the user that owns the Spectrum installation

2. If running Windows, start a bash shell by running "bash -login"

3. Find and note the process id of the SpectroSERVER process.

4. Run the moot trace where <PID> is the process id of the SpectroSERVER process noted in the previous step:

    a. In Linux, run the following command:

kill -USR1 <PID>

    b. On Windows, cd to the $SPECROOT/lib/SDPM directory and run the following command:

./kill -USR1 <PID>

5. Leave the moot trace running for 15-20 minutes

6. Rerun the command to stop the moot trace

7. Upload the following files to the case:

$SPECROOT/SS/.moot.trace
$SPECROOT/SS/VNM.OUT
All of the $SPECROOT/SS/support/Incident.Data files