createsdmjasperjks install error
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createsdmjasperjks install error

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Article ID: 258593

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

During installation, we are seeing this error appear:

install.log may contain these logs:

20XX/XX/XX 11.17.04.841 ERROR [DeployThread: Running Pre Configuration steps for CA Service Desk Manager Update(s) : 17.4] [JasperJKSGenerator] Invalid inputs provided to download file

20XX/XX/XX 12.09.44.771 DEBUG [DeployThread: Running Pre Configuration steps for CA Service Desk Manager Update(s) : 17.3.0.19] [PreConfigurationBase] Return result from execute of createsdmjasperjks is  success ? :false

 

 

Environment

Release : 17.3 & 17.4 GA

CA Service Desk Manager

Cause

The above is being caused by new functionality introduced in RU19 that streamlines the manual Jasper integration process

This can be seen when installing 17.3 RU19 and higher or 17.4 GA and higher

Resolution

Please check if there is a working Jasper installation whose integration may need to be re-examined manually per the above documented steps.

As a workaround, one can modify the <installDVD>\patches\SDM_patch.xml file and remove this line: 

<action type="createsdmjasperjks">CreateSDMJasperJKS</action>

The RU install should then be re-attempted.