Identity Governance Workflow Filter by Date Does Not Work
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Identity Governance Workflow Filter by Date Does Not Work

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Article ID: 258548

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Updated On:

Products

CA Identity Suite

Issue/Introduction

In the Administration > Workflows > Filter  page, it is required to set a “Due Date” filter.  However, the events shown are not filtered correctly. 

 

Environment

Release : 14.4

Cause

Findings:

  1. No matter what date range you set, workflows with a null “Due Date” will always show up.
  2. To pick up a specific date, you have to set the range to 1 day past the day you are looking for.

For example, to see a campaign with a due date of 4/10/22,

the date range must be 4/10/22 to 4/11/22.

 

As we have 24 campaigns in our Prd env with a null Due Date, it would be nice if these didn’t show up when you select a date range.   (ie. There is no way to filter these out)

 

As to why the date range is null:  It looks like most of these were campaigns imported from a prior version of the product.  A few look like campaigns that were created, but never started. 

Resolution

Works as designed.