For CISCO ACI Devices integrated with VNA all the interfaces under the interface tab are showing unreachable in Spectrum
search cancel

For CISCO ACI Devices integrated with VNA all the interfaces under the interface tab are showing unreachable in Spectrum

book

Article ID: 258543

calendar_today

Updated On:

Products

DX NetOps CA Spectrum CA Virtual Network Assurance

Issue/Introduction

 

We've onboarded CISCO ACI devices via VNA plugin in NetOps Performance Management. But if we select any of the leaf or spine in Spectrum we are getting all interfaces in unreachable state.

 

Environment

Release : 21.2.x / 22.2.x

Spectrum with VNA integrated

Cause

Devices must be discovered with SNMP in Spectrum first

Resolution

If the devices are snmp reachable then Spectrum must discover those switches using snmp

Also be sure that the required SNMP Community is set under the Spectrum VNM Model, Information tab -> Auto Discovery control -> protocol tables -> community strings

Once the community string is added, disable the VNA integration - wipes out all sdn based models and then reenable it. 

All the switches must get discovered as snmp devices. In case if they are already discovered through snmp then they will get reconciled too.