ORA-01683 error in data_engine log - QoS not getting inserted
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ORA-01683 error in data_engine log - QoS not getting inserted

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Article ID: 258524

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

We noticed that there are some gaps in QoS data, or QoS is not being inserted up to the current minute.

We are seeing errors like the following in data_engine.log:

OCI_ERROR - ORA-01683: unable to extend index UIM_ADMIN.RN_QOS_DATA_0013_IDX0 partition RN_QOS_DATA_0013$1674691200 by 1024 in tablespace CA_UIM 

Environment

Release : 20.4

Cause

Incorrect database settings.

Resolution

The Oracle DB for UIM is expected to grow to some extent over time.  As more robots, more monitoring, more metrics, and more alarms are enabled, more space will be needed to store the data.

The UIM DB/Tablespace therefore needs to have the options "autoextend on" and "maxextents unlimited" enabled.  

Additional Information

https://www.dba-oracle.com/t_ora_01683_unable_to_extend_index.htm