PAM Device Discovery throws error (nmap)
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PAM Device Discovery throws error (nmap)

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Article ID: 258481

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

Trying to leverage Device Discovery embedded in PAM platform.

Following the directions from this URL:

https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/privileged-access-manager/3-4/implementing/configure-policies-to-provision-user-access-to-devices-and-applications/configure-devices/device-discovery.html

I configured a scan to look for windows 2019 servers in two subnets - 10.xxx.0.0/16 and 10.xxx.0.0/16

The only other configuration I added was Access Methods where I selected RDP (3389)

When I run the scan and navigate to Discovery Jobs it simply returns error under Status.

How can I find what the error might be?

Environment

Release : 4.x

Cause

There are several possible reasons for the network scan to fail.

1. a timeout due to slow network connectivity

2. firewall preventing access

 

 

Resolution

Troubleshooting the specific reasons for the failure can be difficult based on what is returned but you can replicate the responses that PAM receives by issuing the same Linux command we use to search the network.

nmap -T4 -A -oX - -p 22,3389 10.xxx.xxx.0/23

Additionally you can try smaller network segments as this process can take an extremely long period of time.