NolioAgent Service Not Starting After Windows Upgrade
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NolioAgent Service Not Starting After Windows Upgrade

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Article ID: 258440

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Updated On:

Products

CA Release Automation - Release Operations Center (Nolio)

Issue/Introduction

Unable to start NolioAgent service on a server.  When I try to start it I receive an error.

Windows could not start the Nolio Agent on Local computer.

Erorr:1053

Environment

Release : 6.7

Cause

Upgrading the Windows Operating System seems to cause problems with NolioAgent service.

Resolution

Available options for fixing problems introduced by upgrading the Windows OS are:

  1. Uninstall/Reinstall the NolioAgent
  2. Remove/Re-add the NolioAgent Service

 

Remove/Re-add the NolioAgent Service

  1. Open services.msc. Look at the Nolio Agent service and take note of:
    • the service account used to start the agent.
    • the install path of the agent
  2. Open a command prompt - with Run As Administrator, cd to the directory noted in step 1. 
  3. Run the command: remove_deployer_service.cmd
  4. Refresh the services.msc list to make sure the service was gone.
  5. Open the command prompt to re-add the service using the command: install_deployer_service.cmd
    • This returned an error about the service was marked for deletion. This means that we need to reboot. 
    • Reboot
  6. Open the command prompt to re-add the service using the command: install_deployer_service.cmd
  7. Open services.msc and opened the properties for the newly added NolioAgent
    • Select the Log On tab.
    • Specify the username noted in step1 along with its password.
  8. Start the NolioAgent service
  9. Confirm the NolioAgent was reflecting as "Reachable" in the ROC (Release Operations Center). 

 

This KB Article can be used if you are uninstalling/reinstalling the agent on a machine that has multiple instances of the NolioAgent installed: Second install of nolioagent on windows fails