CEM-Enabled Agents are unable to connect to Internet Gateway by external IP
search cancel

CEM-Enabled Agents are unable to connect to Internet Gateway by external IP

book

Article ID: 258357

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

A CEM policy was enabled in the console listing the Internet Gateway by external IP rather than external FQDN. The IP address is correct and externally resolvable. However, when a CEM-Enabled Agent attempts to connect to the Internet Gateway, the logs show that it fails to resolve the CEM Internet Gateway address.

Environment

ITMS 8.6

Cause

The CEM Gateway policy has been seen to use an external IP address that had a hidden extra character entered before the start of the IP. This was validated by selecting the external IP entry in the CEM policy, and then editing the entry. It was noticed that when attempting to arrow over from the start of the line to the first character that it took two keystrokes when it should have taken one:

Resolution

After removing the entire line and re-entering the external IP address, the CEM-Enabled Agents were then able to successfully resolve and connect through the Internet Gateway.