CEM enabled agents are unable to connect to Internet Gateway by external IP
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CEM enabled agents are unable to connect to Internet Gateway by external IP

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Article ID: 258357

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Updated On:

Products

IT Management Suite

Issue/Introduction

A CEM policy was enabled in the console listing the Internet Gateway by external IP rather than external FQDN. The IP address is correct and externally resolvable. However, when a CEM-enabled agent attempts to connect to the gateway, logs show that it fails to resolve the CEM gateway address.

 

Environment

ITMS 8.6

Cause

In one instance of this issue, we found that the CEM Gateway policy used an external IP address that had a hidden extra character entered before the start of the IP.

This was validated by selecting the external IP entry in the CEM policy, and then editing the entry. We noticed that when attempting to arrow over from the start of the line to the first character it took two keystrokes when it should have taken one

 

Resolution

After removing the entire line and re-entering the external IP address, CEM-enabled agents were then able to successfully resolve and connect through the gateway