search cancel

OPMS installation rubygem(rgen) is needed

book

Article ID: 258349

calendar_today

Updated On:

Products

CA App Synthetic Monitor

Issue/Introduction

When we try to install OPMS, install the puppet fails with the following error:

Failed dependencies:
        rubygem(rgen) is needed by puppet-3.6.2-3.el7.noarch".

When we try to install rubygem (rpm -i rubygem-rgen-0.8.4-8.fc37.noarch.rpm) the following error appears: 
        rpmlib(PayloadIsZstd) <= 5.4.18-1 is needed by rubygem-rgen-0.8. 4-8.fc37.noarch.

 

Environment

Release : 10.1

Resolution

You can workaround by doing the following: 

First, do (as root):

rpm -ivh http://yum.puppetlabs.com/el/7/products/x86_64/puppetlabs-release-7-11.noarch.rpm

yum install puppet

And you can proceed with OPMS installation.

Additional Information

EPEL repository will still get installed and additional dependencies pulled from it but we tested the process and it completed smoothly.