Software Policy Failing Install Step
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Software Policy Failing Install Step

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Article ID: 258247

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Updated On:

Products

Client Management Suite IT Management Suite

Issue/Introduction

I have an installation job. The task runs with no issues. I created a software policy to deploy/schedule the installation job. For some reason, the software policy won't run the installation job. It is resulting to "failure". The error code is:

Exit Code 87

Environment

ITMS 8.6

Cause

Incorrect command line parameter

Resolution

Troubleshoting the SW Delivery package install found that it would run successfully as a task but not as the SW delivery policy. It was failing with Exit Code 87. After searching, a vendor Installation guide was found that indicated that there was an install log available. In the log file, it was found that it errored on the /Quiet switch. After removing that switch from the SW Resource > Command Line the policy then succeeded.