PXE boot menu options do not appear in PXE Configuration Utility
search cancel

PXE boot menu options do not appear in PXE Configuration Utility

book

Article ID: 257807

calendar_today

Updated On:

Products

Ghost Solution Suite

Issue/Introduction

The PXE Configuration Utility within Ghost Solution Suite contains no Boot Menu Options for any PXE server or 'Shared Configuration' PXE Servers. The only option listed within PXE Configuration Utility is 'Next Device (BIOS/EFI)'

However, if a PXE boot is attempted, additional menu options are available which were previously created. These menu options are also visible in the \PXE\Images folder on the express share. Attempting to boot to these configurations may fail.

Environment

Ghost Solution Suite 3.x

Cause

In at least one instance of this issue, the GSS server was completely out of space on the installation drive and corruption occurred within the GSS PXE components.

Resolution

If the PXE Configuration Utility shows a blank Boot Menu Options or only shows 'Next Device (BIOS/EFI)', ensure you have selected the 'Shared Configuration' in File > 'Choose PXE Server'. If the menu is still missing previously created PXE configurations, a reinstallation of PXE components should correct the issue.

*NOTE
Reinstalling PXE components will require re-creating PXE boot configurations/Menu Options. It is recommended to take a backup of the GSS server and SQL DB prior to attempting this. If you are unsure of any of the steps below, please contact Broadcom Technical Support for assistance.

Step 1:
Ensure you are signed in to the GSS server using the GSS service account. Open PXE Configuration Utility and make note of all settings configured so these can be reconfigured later. Then close GSS and PXE Configuration Utility and stop all GSS Services

Step 2:
From Windows Programs and Features on the PXE server, uninstall in this order: iPXE add-on's, and PXE Server. Then uninstall PXE Manager from the GSS server (may be on the same server as PXE)

Step 3:
In file explorer, navigate to \Program Files (x86)\Altiris\eXpress\Deployment Server (or location of eXpress share). Rename or delete the folder/directory called 'PXE'

Step 4:
Installation files for the currently installed version by default are located at c:\DSSetup. Navigate to this directory and right click on axinstall.exe > 'Run as administrator'

Check for GSS Installation pre-requisites to ensure 'Server Check Summary' passes all requirements.

In testing, a full 'Custom Install' has been successful in reinstalling PXE and PXE Manager. If this option is selected, ensure you select 'yes' to use the existing DB and eXpress share.

If you would prefer not running the full installation, the issue may be resolved by repairing PXE Manager from 'Component Install', then installing PXE server components.

Step 5:
Create new PXE Configurations/Menu items and ensure settings in PXE Configuration Utility are correct.