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AAI gantt chart not loading: "The selected jobstream is currently unavailable. Please wait a few moments..."

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Article ID: 257755

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Updated On:

Products

Automic Automation Intelligence

Issue/Introduction

When selecting a jobstream from the analysis tab, the gantt chart does not load and the message below is displayed:
 
"The selected jobstream is currently unavailable. Please wait a few moments..."

 

 

 

Environment

Release : 6.4.2-1

Cause

When looking at the jaws.log the error below could be seen:

 

WARN  [JammerManager] task failed.: java.lang.OutOfMemoryError: Java heap space

ERROR [JammerManager] Interrupted: com.termalabs.common.JawsException: Error occurred in task.
    at com.termalabs.server.system.JammerManager.runTasksInParallel(JammerManager.java:874)
    at com.termalabs.server.system.JammerManager.runJammers(JammerManager.java:697)
    at com.termalabs.server.system.JammerManager.run2(JammerManager.java:321)
    at com.termalabs.server.system.JammerManager.run(JammerManager.java:238)
    at com.termalabs.server.system.ApplicationControllerService$2.run(ApplicationControllerService.java:268)
    at java.util.TimerThread.mainLoop(Timer.java:555)
    at java.util.TimerThread.run(Timer.java:505)

Resolution

The error indicated that AAI was running out of allocated memory.

 

You can update the memory configuration in the AAI Configuration tool.

 

This is located in your <Install Dir>/Config directory.

On linux you will need x11 forwarding to launch the configuration rool, and it is launched by running ./run.sh from the directory mentioned above.

 

Once you are in the configuration tool, go to the Other tab, where you will see a section for "Java VM Options" this is where you set the Min and Max memory.

 

https://api-broadcom-ca.wolkenservicedesk.com/attachment/get_attachment_content?uniqueFileId=h4UO3Z7D0ntRhQZnNw+MAA==

 

There is a Sizing Worksheet available on this page: https://docs.automic.com/documentation/webhelp/english/ALL/components/TERMA/latest/AAI%20Guides/Content/Install_Upgrade/Install_Preparing.htm?tocpath=Installation%20and%20Upgrade%7CInstalling%20AAI%7C_____1

 

This will give you some guidelines on how much memory should be allocated.

It depends on the number of schedulers you have and how many jobs are in each scheduler.

Below is what the sizing sheet looks like, and you just enter your details into the Yellow boxes and it will give you a rough idea of how much memory should be allocated to the AAI application in the configuration tool.

 

https://api-broadcom-ca.wolkenservicedesk.com/attachment/get_attachment_content?uniqueFileId=GT8mkZtKOLcjjIAkXUT1Pg==

 

 

Once the memory setting is updated, you must restart AAI for the change to take affect.

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